[rosa-devel] python3 and rosa

symbianflo at mandrivausers.ro symbianflo at mandrivausers.ro
Sat Dec 28 15:49:33 MSK 2013


Il 28/12/2013 09:20, Denis Silakov ha scritto:
> On 12/28/13 00:04, symbianflo at mandrivausers.ro wrote:
>> Hi
>> I'd like to know if a pythonegg(module) is in main , same module  
>> but  python3egg(module) can be forked in contrib?
>> I mean , we have a lot of missing or old/obsoletes  python3 modules, 
>> bur the same module for
>> abi 2.7 is in main, so is out of reach for me, now It is possible to 
>> have python3 in contrib?
>
> Your example with django is very good, indeed. I guess it is located 
> in main just for historical reasons, we should definitely move such 
> stuff out from main in future.
>
>> Until you decide to switch to python3 as default python abi ?
> <...>
>> Since more and more distros are switching to abi 3.3 as default I 
>> think we should have it , at least
>> in contrib, if not all 2.7 modules  at least 1/2 of them...
> I think we won't switch to python3 as default at least in the next 
> version of Desktop Fresh. Fedora has been moving towards python3 as 
> default for several years and is still not ready to perform such a 
> switch. Though I can see a lot of recent activities in this way 
> (https://bugzilla.redhat.com/show_bug.cgi?id=1014209, 
> https://fedoraproject.org/wiki/Changes/Python_3_as_Default) and they 
> hope to switch to python3 in F22. Let's see.
>
> To be sure, developers of python itself want all of us to switch to 
> python3 (and python2.x is in maintenance mode now, but support is 
> guaranteed until May, 2015). Unfortunately, there are still a lot of 
> applications that were not migrated to python3. No wonder that one of 
> the steps in Fedora's plan is to help upstream apps to migrate to 
> python3...
>
> --
> Regards,
> Denis.
>
>
> _______________________________________________
> rosa-devel mailing list
> rosa-devel at lists.rosalab.ru
> http://lists.rosalab.ru/mailman/listinfo/rosa-devel
We ( me and you),  already had this talk :D  I was targeting the other
packagers with my mail :D .
I would gladly here Bondrov's POV about this... same build for both abi
or separate branches ?
And that we need 3.x abi is obvious ...
if not now , next year for sure..., and beside fedora , is arch, sabayon,
fuduntu,a.s.o , they did not drop the 2.7, of course, just follow the 
python
policy ...2.7 is no longer developed period... like gambas2, qt3, gtk2 
....a.s.o.

-- 
Greetings

___________________

MRB ain't no shit

Rosalinux.Ro

Mandrivausers.Ro

________________

Talk is cheap, show me the code.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rosalab.ru/pipermail/rosa-devel/attachments/20131228/ea7d929b/attachment.html>


More information about the rosa-devel mailing list