[rosa-devel] [Rosa-users] corrupted NVidia updates

Alexander Kazancev alexander.kazantsev at rosalab.ru
Sat May 4 11:47:27 MSK 2013


I say again - we test update in many machines and all worked. More than -
newest version not worked in some machines. 313.30 not work in GTX card,
broke bumblebee, 319.17 not build anymore in Fresh from source - it has
some error in code :(. We has only two report about broked update and
problem with resolving via reconfigure from XFdrake.

04.05.2013 11:33 пользователь "Sylvain ZUCCA" <sylvainsjc at gmail.com>
написал:
>
> Well, I've tried a lot of things with the NVidia 313.26 from repositories
but no way to make it work.
>
> At the end, I've downloaded last driver NVidia.run (319.17) from NVidia
site and installed it. All is working well with this release.
>
> What will you do to prevent others from experiencing this problem? This
version should be removed from the non-free updates.
>
>
>
>
> 2013/5/3 Alexander Kazancev <alexander.kazantsev at rosalab.ru>
>>
>> You card not work with nouveau - this is say for (may be) problem with
you video card - nouveau did work with it! Try use nvidia-long-lived - may
be some problem with latest driver model and you card i think.
>>
>> Also, if you has some problem with nouveau, try blacklist it - add
'nouveau' to /etc/modprobe.d/blacklist-compat.conf
or /etc/modprobe.d/blacklist-mdv.conf
>>
>> Than you need see alternatives - run (from root)
>>
>> update-alternatives --config gl_conf
>>
>> and set number of line /etc/nvidia-current/ld.so.conf
>>
>>
>>
>> 2013/5/3 Sylvain ZUCCA <sylvainsjc at gmail.com>
>>>
>>> My NVidia model card is 9600GT
>>>
>>> I get a graphical screen only if I set "vesa". As soon as I configure
with NVidia using (or not) proprietary drivers, at reboot, it stay on a
black screen.
>>>
>>>
>>> [root at Rosa2012Fresh ~]# uname -r
>>> 3.6.10-nrj-desktop-1rosa
>>> [root at Rosa2012Fresh ~]#
>>>
>>>
>>> [root at Rosa2012Fresh ~]# dkms_autoinstaller start
>>>
>>> nvidia-current (313.26-5): Already installed on this kernel.
>>> vboxadditions (4.2.12-1): Already installed on this kernel.
>>> vboxhost (4.2.12): Already installed on this kernel.
>>> [root at Rosa2012Fresh ~]#
>>>
>>> [root at Rosa2012Fresh ~]# rpm -qa | grep kernel-nrj-desktop-devel
>>> kernel-nrj-desktop-devel-3.6.10-1rosa-1-1-rosa2012.1.x86_64
>>> kernel-nrj-desktop-devel-latest-3.6.10-1-rosa2012.1.x86_64
>>> [root at Rosa2012Fresh ~]#
>>>
>>>
>>>
>>>
>>> 2013/5/3 Alexander Kazancev <alexander.kazantsev at rosalab.ru>
>>>>
>>>> And what model videocard you has?
>>>>
>>>>
>>>> 2013/5/3 Sylvain ZUCCA <sylvainsjc at gmail.com>
>>>>>
>>>>> I rebooted once ==> Fail
>>>>> I press Ctrl-Alt-F2, log as root, run XFDrake and setup my card with
proprietary drivers  ==> Fail
>>>>> I added 'nomodeset" in grub kernel line ==> Fail
>>>>>
>>>>> Screen still black !!!
>>>>>
>>>>> here the Xorg.0.log file, you can see these errors :
>>>>>
>>>>> [     8.389] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel
module. Please see the
>>>>> [     8.389] (EE) NVIDIA(0):     system's kernel log for additional
error messages and
>>>>> [     8.389] (EE) NVIDIA(0):     consult the NVIDIA README for
details.
>>>>> [     8.389] (EE) NVIDIA(0):  *** Aborting ***
>>>>> [     8.389] (EE) NVIDIA(0): Failing initialization of X screen 0
>>>>> [     8.389] (II) UnloadModule: "nvidia"
>>>>> [     8.389] (II) UnloadSubModule: "wfb"
>>>>> [     8.389] (EE) Screen(s) found, but none have a usable
configuration.
>>>>>
>>>>>
>>>>> 2013/5/3 Alexander Kazancev <alexander.kazantsev at rosalab.ru>
>>>>>>
>>>>>> Also users setup drivers manually and miss STRONGLY needing option
'nomodeset'. I don't know why previous driver worked without it, but 313
driver and upper DON'T WORK without it. User simple need add 'nomodeset' in
kernel line and will not setup nvidia and amd driver manually without
XFdrake!
>>>>>>
>>>>>>
>>>>>> 2013/5/3 Alexander Kazancev <alexander.kazantsev at rosalab.ru>
>>>>>>>
>>>>>>> Don't panic!
>>>>>>>
>>>>>>> 1. Reboot - for second reboot all may be work!
>>>>>>> 2. If did not work - press Ctrl+F2 - login as root - run XFdrake
and setup you card again
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> 2013/5/3 Julia Dronova <jdronova at pingwinsoft.ru>
>>>>>>>>
>>>>>>>> Hello people,
>>>>>>>> We have already 2 forum reports of black screen after today's
NVidia udate.
>>>>>>>> http://forum.rosalab.ru/en/viewtopic.php?f=39&t=1967&p=15985#p15973
>>>>>>>> http://forum.rosalab.ru/en/viewtopic.php?f=15&t=1976
>>>>>>>>
>>>>>>>> Please roll it back or fix the situation ASAP.
>>>>>>>> Users please refrain from updating NVidia until better weather
conditions.
>>>>>>>>
>>>>>>>> ----
>>>>>>>> best regards,
>>>>>>>> Julia Dronova, ROSA Labs
>>>>>>>>
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Rosa-users mailing list
>>>>>>>> Rosa-users at lists.rosalab.ru
>>>>>>>> http://lists.rosalab.ru/mailman/listinfo/rosa-users
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Alexander Kazancev
>>>>>>> Release manager of ROSA Desktop distribution
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Alexander Kazancev
>>>>>> Release manager of ROSA Desktop distribution
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> Rosa-users mailing list
>>>>>> Rosa-users at lists.rosalab.ru
>>>>>> http://lists.rosalab.ru/mailman/listinfo/rosa-users
>>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Alexander Kazancev
>>>> Release manager of ROSA Desktop distribution
>>>>
>>>
>>
>>
>>
>> --
>> Alexander Kazancev
>> Release manager of ROSA Desktop distribution
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rosalab.ru/pipermail/rosa-devel/attachments/20130504/d73137e4/attachment.html>


More information about the rosa-devel mailing list