[rosa-devel] Problems updating rpm

cristobal lopez silla lopeztobal at gmail.com
Thu May 16 11:26:34 MSK 2013


tobal at tobal ~ $ urpmq --sources flash-player-plugin
rosa-elementary-dark-theme
http://mirror.rosalab.ru/rosa2012lts/repository/x86_64/media/main/updates/rosa-elementary-dark-theme-2.4.2-8-rosa.lts2012.0.noarch.rpm
http://mirror.rosalab.ru/rosa2012lts/repository/x86_64/media/non-free/release/flash-player-plugin-11.2.202.233-4-rosa.lts2012.0.x86_64.rpm
http://mirror.rosalab.ru/rosa2012lts/repository/x86_64/media/non-free/updates/flash-player-plugin-11.2.202.280-1-rosa.lts2012.0.x86_64.rpm
tobal at tobal ~ $



2013/5/16 Denis Silakov <denis.silakov at rosalab.ru>

>  Let's check - what does the following command say:
>
> urpmq --sources flash-player-plugin rosa-elementary-dark-theme
>
> ?
>
>
> On 05/16/2013 11:08 AM, cristobal lopez silla wrote:
>
> Ok, here you are my urpmi.cfg
>
> {
> }
>
> OwnRepo file://home/tobal/Repositorio {
>   no-media-info
>   update
> }
>
> main\ (Desktop2012.1-1)  {
>   key-ids: 16a853e7
>   mirrorlist: $MIRRORLIST
>   with-dir: media/main/release
> }
>
> main\ updates\ (Desktop2012.1-2)  {
>   key-ids: 16a853e7
>   mirrorlist: $MIRRORLIST
>   update
>   with-dir: media/main/updates
> }
>
> contrib\ (Desktop2012.1-3)  {
>   mirrorlist: $MIRRORLIST
>   with-dir: media/contrib/release
> }
>
> contrib\ updates\ (Desktop2012.1-4)  {
>   mirrorlist: $MIRRORLIST
>   update
>   with-dir: media/contrib/updates
> }
>
> non-free\ (Desktop2012.1-5)  {
>   key-ids: 16a853e7
>   mirrorlist: $MIRRORLIST
>   with-dir: media/non-free/release
> }
>
> non-free\ updates\ (Desktop2012.1-6)  {
>   key-ids: 16a853e7
>   mirrorlist: $MIRRORLIST
>   update
>   with-dir: media/non-free/updates
> }
>
> restricted\ (Desktop2012.1-7)  {
>   key-ids: 16a853e7
>   mirrorlist: $MIRRORLIST
>   with-dir: media/restricted/release
> }
>
> restricted\ updates\ (Desktop2012.1-8)  {
>   key-ids: 16a853e7
>   mirrorlist: $MIRRORLIST
>   update
>   with-dir: media/restricted/updates
> }
>
> Tobal
> http://abf.rosalinux.ru/downloads/tobal_personal/repository/rosa2012.1/x86_64/main/release{
>   update
> }
>
> Grissino
> http://abf.rosalinux.ru/downloads/grissino0_personal/repository/rosa2012.1/x86_64/main/release{
>   update
> }
>
> Symbianflo
> http://abf.rosalinux.ru/downloads/symbianflo_personal/repository/rosa2012.1/x86_64/main/release{
>   update
> }
>
> Kernel
> http://abf.rosalinux.ru/downloads/kernels_38x_personal/repository/rosa2012.1/x86_64/main/release{
>   update
> }
>
> Mib http://mib.pianetalinux.org/MIB/rosa2012.1/64/basic {
>   update
> }
>
> Mesa64 http://mib.pianetalinux.org/MIB/rosa2012.1/64/testing/mesa-xorg {
>   update
> }
>
> Mesa32 http://mib.pianetalinux.org/MIB/rosa2012.1/32/testing/mesa-xorg {
>   ignore
>   update
> }
>
> Kde410
> http://abf.rosalinux.ru/downloads/kde4_backports_personal/repository/rosa2012.1/x86_64/main/release{
>   update
> }
>
>
>
> 2013/5/16 Denis Silakov <denis.silakov at rosalab.ru>
>
>>  That's right, 2012.1 are the correct repos.
>>
>> But if you carefully look at your log, you will see that urpmi is
>> claiming about rpm-5.4.10-9 with "rosa.lts2012.0" package. So somehow you
>> get dependencies on 2012lts repositories.
>>
>> Maybe you have some other repositories enabled which depends on packages
>> from 2012lts? Could you provide the whole list of enabled repositories (or
>> simply /etc/urpmi/urpmi.cfg file)?
>>
>>
>> On 05/16/2013 10:44 AM, cristobal lopez silla wrote:
>>
>> Now i have a mess. Fresh, Marathon? Can you put me here what are the
>> correct Fresh repos? I have 2012.1 installed, so repos are 2012.1, not
>> 2012lts repos, or not?
>>
>>
>>  2013/5/16 Denis Silakov <denis.silakov at rosalab.ru>
>>
>>> From your log I can see that you have both Marathon and Desktop Fresh
>>> repositories enabled at the same time. This is not recommended and can lead
>>> to problems, as in your case.
>>>
>>> rpm-5.4.10-9 is now in Marathon, while rpm-5.4.10-7 is in Fresh.
>>>
>>>
>>> On 05/15/2013 06:44 PM, tobal wrote:
>>>
>>>>  Hi, i've got rosa 2012.1 64 bits
>>>> My rosa wants update rpm, I've got installed 5.4.10-7 version and my
>>>> Rosa wants update to 5.4.10-9 version but i've got problems because this
>>>> latest version not appear in the repo lists, so it cannot find it
>>>> I take 3 or 4 days with this problem, and I cannot update/install any
>>>> package via repositories.
>>>>
>>>> Thanks
>>>>   _______________________________________________
>>>> rosa-devel mailing list
>>>> rosa-devel at lists.rosalab.ru
>>>> http://lists.rosalab.ru/mailman/listinfo/rosa-devel
>>>>
>>>
>>>
>>> --
>>> Denis Silakov, ROSA Laboratory.
>>> www.rosalab.ru
>>>
>>>
>>> _______________________________________________
>>> rosa-devel mailing list
>>> rosa-devel at lists.rosalab.ru
>>> http://lists.rosalab.ru/mailman/listinfo/rosa-devel
>>>
>>
>>
>>
>> _______________________________________________
>> rosa-devel mailing listrosa-devel at lists.rosalab.ruhttp://lists.rosalab.ru/mailman/listinfo/rosa-devel
>>
>>
>>
>> --
>> Denis Silakov, ROSA Laboratory.www.rosalab.ru
>>
>>
>> _______________________________________________
>> rosa-devel mailing list
>> rosa-devel at lists.rosalab.ru
>> http://lists.rosalab.ru/mailman/listinfo/rosa-devel
>>
>>
>
>
> _______________________________________________
> rosa-devel mailing listrosa-devel at lists.rosalab.ruhttp://lists.rosalab.ru/mailman/listinfo/rosa-devel
>
>
>
> --
> Denis Silakov, ROSA Laboratory.www.rosalab.ru
>
>
> _______________________________________________
> rosa-devel mailing list
> rosa-devel at lists.rosalab.ru
> http://lists.rosalab.ru/mailman/listinfo/rosa-devel
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rosalab.ru/pipermail/rosa-devel/attachments/20130516/a63cc714/attachment.html>


More information about the rosa-devel mailing list