[rosa-devel] Kernel 3.14.9: finally VMware 10 fully works also with OpenMandriva 2014 and K 3.14

Nicolò Costanza abitrules at yahoo.it
Sat Jun 28 16:35:25 MSK 2014


Hi


Kernel 3.14.9 for ROSA 2012 2012.1 2014.1 OMV2013 2014 2015
http://mib.pianetalinux.org/forum/viewtopic.php?f=38&t=4429




It was a pity there is a strange issue with kernel 3.14.x on omv2014 with VMware,
while with Rosa Fresh R3 all was/is fine, with the Guide we published on the MIB:
>>> http://mib.pianetalinux.org/forum/viewtopic.php?p=23886#p23886



the error was:
- vmware could not start the vmware service (/etc/init.d/vmware) at all
a strange warning about DHCP is already running, and for a misterious reason, at least to me,
it did not load the vmware service, the VMs started without vmnet, so NO Internet is available...




All that happened with the kernel 3.14.6and upto 3.14.8, even if the patches for 3.14 were applied.


With kernel 3.14.9, just installed, it's really weird, but now vmware works with net, vmware loaded!
and so it's possible to show OpenMandriva 2014 with VMware VMs guests running on kernel 3.14

(I mean during the French event at MontPellier)



from here (here my logs):
You can see that only when I rebooted with 3.14.9, at > giu 28 13:39:33 > all is finally perfect with it!



[root at localhost ~]# systemctl status vmware.service
vmware.service - SYSV: This service starts and stops VMware services
 Loaded: loaded (/etc/rc.d/init.d/vmware)
 Active: failed (Result: exit-code) since sab 2014-06-28 12:34:10 CEST; 1h 6min ago
 Process: 9450 ExecStart=/etc/rc.d/init.d/vmware start (code=exited, status=1/FAILURE)
 CGroup: /system.slice/vmware.service
 5241 /usr/lib/vmware/bin/vmware-vmblock-fuse -o subtype=vmware-vmblock,default_permissi...
 5450 /usr/sbin/vmware-authdlauncher
 9555 /usr/bin/vmnet-bridge -s 6 -d /var/run/vmnet-bridge-0.pid -n 0
 9563 /usr/bin/vmnet-netifup -s 6 -d /var/run/vmnet-netifup-vmnet1.pid /dev/vmnet1 vmnet...
 9576 /usr/bin/vmnet-natd -s 6 -m /etc/vmware/vmnet8/nat.mac -c /etc/vmware/vmnet8/nat/n...



(this happened me with kernel 3.14.6 and with 3.14.8)
giu 28 12:34:10 localhost.localdomain systemd[1]: vmware.service: control process exited, code=ex...s=1
giu 28 12:34:10 localhost.localdomain systemd[1]: Failed to start SYSV: This service starts and s...es.
giu 28 12:34:10 localhost.localdomain systemd[1]: Unit vmware.service entered failed state.



(this with kernel 3.14.9, after installed, at the first reboot)
giu 28 13:39:33 localhost.localdomain vmnet-natd[9576]: RTM_DELROUTE: index:3
giu 28 13:39:33 localhost.localdomain vmnetBridge[9555]: RTM_DELROUTE: index:3
giu 28 13:39:33 localhost.localdomain vmnet-natd[9576]: RTM_DELADDR: index:3, addr:192.168.1.202
giu 28 13:39:33 localhost.localdomain vmnetBridge[9555]: RTM_NEWLINK: name:wlan0 index:3 flags:0x0...03
giu 28 13:39:33 localhost.localdomain vmnetBridge[9555]: Removing interface wlan0 index:3
giu 28 13:39:33 localhost.localdomain vmnet-natd[9576]: RTM_NEWLINK: name:wlan0 index:3 flags:0x00...03
giu 28 13:39:33 localhost.localdomain vmnetBridge[9555]: Stopped bridge wlan0 to virtual network 0.
[root at localhost ~]#



thanks for Your attention
bye, NicCo
-
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rosalab.ru/pipermail/rosa-devel/attachments/20140628/f0a014a5/attachment.html>


More information about the rosa-devel mailing list