[rosa-devel] python-pep8 && python3-pep8 to be gone

Andrey Bondrov andrey.bondrov at rosalab.ru
Fri Jun 2 06:23:31 MSK 2017


В Thu, 1 Jun 2017 22:21:47 +0200
symbianflo <symbianflo на mandrivausers.ro> пишет:

> hi folx
> pep8 was renamed as pycodestyle;
> https://github.com/PyCQA/pycodestyle/issues/466
> 
> the git on github is already renamed and the files also.
> I'm building pycodestyle and drop pep8.

Please note that some time ago you already imported pycodestyle as
https://abf.rosalinux.ru/import/python-codestyle

I suggest to drop python-codestyle package and obsolete it in
python-pycodestyle. 

python-pycodestyle is better package name than python-codestyle because
other distributions have python-pycodestyle. So it'll be easier to
compare packages and track new versions.

> As for BR and req that ask for pep8 I've found only:
> https://abf.rosalinux.ru/import/ganeti

Looks like we dropped ganeti from rosa2014.1 & rosa2016.1 repositories.
So we don't have to care about it anymore.

Packages that have pep8 in BuildRequires:
https://abf.rosalinux.ru/import/d-feet
https://abf.rosalinux.ru/import/ovirt-guest-agent

Package that depends on pythonegg(pycodestyle) and
python3egg(pycodestyle) in BuildRequires:
https://abf.rosalinux.ru/import/python-flake8


More information about the rosa-devel mailing list