[Triage-desktop] [Bug 5246] gives error: undefined symbol: TLSv1_1_client_method

bugzilla-daemon bugzilla-daemon at rosalab.ru
Sun Mar 22 12:42:26 MSK 2015


http://bugs.rosalinux.ru/show_bug.cgi?id=5246

--- Comment #3 from Denis Silakov <denis.silakov at rosalab.ru> ---
(In reply to comment #2)
> A corrupted copy of wget on the repos?

No. Here is the culprit:

>         libssl.so.1.0.0 => /usr/StorMan/ssl/lib/libssl.so.1.0.0
>         libcrypto.so.1.0.0 => /usr/StorMan/ssl/lib/libcrypto.so.1.0.0

You have 'StorMan' installed in your system which overlaps system OpenSSL
libraries. In normal situation, you would get the output like this:

 libssl.so.1.0.0 => /usr/lib64/libssl.so.1.0.0
 libcrypto.so.1.0.0 => /usr/lib64/libcrypto.so.1.0.0


It looks like OpenSSL libraries in StorMan are too old and don't provide
symbols necesary for our wget and other problems. The simplest way to resolve
your issues is to remove StorMan (since this is not a package from our
repositories, we can't fix it by ourselves).

Alternatively, you can take a look at your LD_LIBRARY_PATH variable:

$ echo $LD_LIBRARY_PATH

It's likely that this variable contains path to /usr/StorMan/ssl/lib. If so,
then try to launch wget in the following way:

$ LD_LIBRARY_PATH='' wget

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rosalab.ru/pipermail/triage-desktop/attachments/20150322/3144c4c7/attachment.html>


More information about the Triage-desktop mailing list