[Triage-desktop] [Bug 7411] New: OpenOffice 4.1.2 crash on startup on all R8.Fresh flavors except R8.MATE

bugzilla-daemon bugzilla-daemon at rosalab.ru
Wed Oct 5 02:13:48 MSK 2016


http://bugs.rosalinux.ru/show_bug.cgi?id=7411

          Priority: Normal
            Bug ID: 7411
          Assignee: triage-desktop at lists.rosalab.ru
           Summary: OpenOffice 4.1.2 crash on startup on all R8.Fresh
                    flavors except R8.MATE
        QA Contact: triage-desktop at lists.rosalab.ru
          Severity: normal
    Classification: ROSA Desktop
                OS: Linux
       RPM Package: http://downloads.sourceforge.net/project/openofficeorg
                    .mirror/4.1.2/binaries/en-US/Apache_OpenOffice_4.1.2_L
                    inux_x86-64_install-rpm_en-US.tar.gz
          Reporter: torokhov_s_a at mail.ru
          Hardware: All
            Status: CONFIRMED
           Version: Fresh
         Component: -Enter Bugs Here-
           Product: Desktop Bugs

Created attachment 4546
  --> http://bugs.rosalinux.ru/attachment.cgi?id=4546&action=edit
gdb ./soffice.bin

Description of problem:

I tried to launch Apache OpenOffice 4.1.2 (AOO, installed or from local
directory) that I downloaded from official site and application crash on
startup.
I use R7.Fresh.KDE updated to actual state. Also I tried to lauch AOO on some
others flavors in Live mode on VirtualBox: R8.Fresh.[KDE | GNOME | PLASMA] and
result was the same except R8.Fresh.MATE and also R6.Fresh.LXQT where startup
of application was successful and work.

This applicaiton from the same RPM package succesfully launched on CensOS
(installed in VirtualBox); Mageia 5, OpenMandriva Lx 3 (both in Live mode in
VirtualBox) so package is not corrupted.


Steps to Reproduce:
The simplest way to reproduce without installation (Live mode is also
acceptable to check)

$ mkdir ./temp
$ cd ./temp
$ wget
http://downloads.sourceforge.net/project/openofficeorg.mirror/4.1.2/binaries/en-US/Apache_OpenOffice_4.1.2_Linux_x86-64_install-rpm_en-US.tar.gz
$ tar -xvf Apache_OpenOffice_4.1.2_Linux_x86-64_install-rpm_en-US.tar.gz
$ cd ./en-US/RPMS
$ for i in ./*.rpm; do rpm2cpio $i | cpio -idvm; done
$ cd ./opt/openoffice4/program
$ ./soffice[/code]


Actual Result:

$ ./soffice
javaldx: Could not find a Java Runtime Environment!
terminate called after throwing an instance of
'com::sun::star::loader::CannotActivateFactoryException'
Application Error

Fatal exception: Signal 6
./soffice: line 121:  4841 Aborted                 (core dumped)
"$sd_prog/$sd_binary" "$@"


Expected Result:

Application (OpenOffice) starts successfully (maybe just with or without
notification "javaldx: Could not find a Java Runtime Environment!" depends on
jre or jdk installation presence in system).

Please NOTE that application starts successfully on R8.Fresh.MATE,
R6.Fresh.LXQT and crash on other R8.Fresh flavors (KDE, GNOME, PLASMA).

Also I attached "gdb ./soffice.bin" output for "run" and "where" (see
attachment).

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rosalab.ru/pipermail/triage-desktop/attachments/20161004/52e4536f/attachment-0001.html>


More information about the Triage-desktop mailing list